Child pages
  • rsMap3D Installation Instructions
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 3 Next »

Installation instructions have been prepared for Linux, OSX and Windows.  These installation instructions assume the use of a  commercial distribution/packaging of Python called Enthought Canopy.  This was used since the APS has invested in licensing and in increasing the knowledge base with the use of a single python distribution.  We are currently using Enthought Canopy version 1.4.0.  This provides a number of installed packages.  There are a number of known package dependencies which are available for installation through the Canopy Package Manager.  These include:

numpy 1.8.0-1  Already installed in Canopy 1.4.0 for all tested platforms

PyQt 4.10.3-1 Needs to be installed through Canopy Package Manager on some platforms (see platform instructions)

vtk 5.10.1-1 Needs to be installed through Canopy Package Manager on some platforms. (see platform instructions)

pytables 2.4.0-5 Needs to be installed through Canopy Package Manager on some platforms. (see platform instructions)

The following packages are available through the Canopy Package manager but are typically older distributions.  It is recommended to manually install these from source following instructions in the platform specific install instructions.

xrayutilities - currently using 1.0.6

pyspec - currently pulling current source from github

Platform Specific Installation Instructions

Linux

OSX

Windows

 

A set of instructions for installing on Windows were written by Christian Schleputz (ANL/XSD) and Yongsoo Yang (University of Michigan).  Many of the steps are applicable on all platforms and some notes have been added to point out some of the differences so that this can be applied more universally.

 

  • No labels